The C-Brats Forum Index
HomeForumsMy TopicsCalendarEvent SignupsMemberlistOur C-DorysThe Brat MapPhotos

2006 honda bf90a, tach/hour issues

 
Post new topic   Reply to topic    The C-Brats Forum Index -> Electrical and Wiring
View previous topic :: View next topic  
Author Message
krc



Joined: 06 Nov 2017
Posts: 26
City/Region: SF Bay Area
State or Province: CA
C-Dory Year: 2006
C-Dory Model: 25 Cruiser
PostPosted: Mon Jul 27, 2020 10:06 pm    Post subject: 2006 honda bf90a, tach/hour issues Reply with quote

Hi -
I have been seeing random tach errors on my port engine. It will be at 3500 cruising then jump up to 6k, back down, then just wildly fluctuates. Engine is not changing rpm based on what I can hear. It has been going on for a year, but not too annoying as most of the time it works fine. Now the hour meter on the starboard tachometer is not showing any hours. No digits whatsoever.

Any ideas? I guess I need to pull the tachs off and check the connections. Or is the "no digits" on the hour meter indicative of a general meter failure?

Thanks
Back to top
View user's profile Send private message Send e-mail
journey on



Joined: 03 Mar 2005
Posts: 3376
City/Region: Valley Centre
State or Province: CA
C-Dory Year: 2005
C-Dory Model: 25 Cruiser
Vessel Name: journey on
Photos: Journey On
PostPosted: Mon Jul 27, 2020 11:06 pm    Post subject: Reply with quote

I'll mention that I had problems with the Honda tachometer on Journey On. It would read a very low rpm, then a high on, without the engine sounding any different. I'd hit it a couple of times and then it'd settle down.So, I finally pulled it out. It was a Faria gauge. Ordered a new one and installed it. Identical fit which now says "Faria" instead of "Honda". With a new clock.

Boris
Back to top
View user's profile Send private message Visit poster's website
thataway



Joined: 02 Nov 2003
Posts: 18038
City/Region: Pensacola
State or Province: FL
C-Dory Year: 2007
C-Dory Model: 25 Cruiser
Vessel Name: thataway
Photos: Thataway
PostPosted: Tue Jul 28, 2020 10:25 am    Post subject: Reply with quote

Start off with cleaning all connections with spray on contact cleaner, plug in and out at the plugs, and burnish an ring terminals. You may want to apply a very small amount of conductive grease to contacts when re-assembled.

If that doesn't correct the issue, then change out the gauges.

Check for 12 volts when the ignition is on (include cleaning ignitions wire connectors).

_________________
Bob Austin
Thataway
Thataway (Ex Seaweed) 2007 25 C Dory May 2018
Thisaway 2006 22' CDory November 2011 to May 2018
Caracal 18 140 Suzuki 2007 to present
Thataway TomCat 255 150 Suzukis June 2006 thru August 2011
C Pelican; 1992, 22 Cruiser, 2002 thru 2006
Frequent Sea; 2003 C D 25, 2007 thru 2009
KA6PKB
Home port: Pensacola FL
Back to top
View user's profile Send private message Send e-mail
krc



Joined: 06 Nov 2017
Posts: 26
City/Region: SF Bay Area
State or Province: CA
C-Dory Year: 2006
C-Dory Model: 25 Cruiser
PostPosted: Wed Jul 29, 2020 8:50 pm    Post subject: Tach... Reply with quote

Removed terminals, cleaned as best I could, checked that with ignition "on" I was getting voltage to the unit (12v or so) - same as on the port tach. Still no display for the hour meter. I guess time to replace. Thinking same unit best otherwise it wouldn't match to the port tach.

Anyone have a part number? I am thinking the BF90 was using this:
37250-ZW5-010ZA

Or better alternative part#?
Thx
Back to top
View user's profile Send private message Send e-mail
VicC



Joined: 20 Sep 2012
Posts: 6
City/Region: El Sobrante
State or Province: CA
C-Dory Year: 2007
C-Dory Model: 22 Angler
Vessel Name: Denali
PostPosted: Wed Jul 29, 2020 9:36 pm    Post subject: Reply with quote

I have twin 50s and have noticed a similar issue with my starboard tach. The tach would display excessive RPMs when running the throttles about the same. No difference in sound of motors.
I tested this while running the 50s at idle. After they warmed up a bit, the port displayed just a hair under 1K. The starboard displayed 2 to 2.5K. Using a multi-meter set to Hz, I checked between common and signal on the tachometer wire landing posts. Both tachs were at around 23-24Hz (if I remembering correct). The idling sound test also told me that the tach display was not true. I just wanted to confirm that there was no "racing" of the starboard. I have not looked into getting a new tach yet. After they continued to run & warm, they both settled in at just under 1K rpm.
Back to top
View user's profile Send private message
journey on



Joined: 03 Mar 2005
Posts: 3376
City/Region: Valley Centre
State or Province: CA
C-Dory Year: 2005
C-Dory Model: 25 Cruiser
Vessel Name: journey on
Photos: Journey On
PostPosted: Thu Jul 30, 2020 12:01 pm    Post subject: Reply with quote

That's the correct Honda part number. It's a Faria tach with a Honda label. The equivalent Faria tach is: Faria Model 32840; black, 7000 rpm, hour meter.

I'd get whatever is cheaper, they're the same tach.

Boris
Back to top
View user's profile Send private message Visit poster's website
johnbenj



Joined: 14 Jul 2007
Posts: 99
City/Region: Bainbridge Island
State or Province: WA
C-Dory Year: 1990
C-Dory Model: 22 Cruiser
Vessel Name: Amoreena
Photos: Rabbit Rabbit
PostPosted: Thu Jul 30, 2020 4:27 pm    Post subject: same here Reply with quote

I see the same thing on my 199x BF90a's Tach. I tap the glass a couple of times and it comes back down to where it should be. The engine noise never changes so i accept it as a mechanical issue due to the vibration of running etc. I also trust my ear more than the tach anyway.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The C-Brats Forum Index -> Electrical and Wiring All times are GMT - 6 Hours
Page 1 of 1

 
     Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum



Page generation time: 0.0658s (PHP: 57% - SQL: 43%) - SQL queries: 24 - GZIP disabled - Debug on