The C-Brats Forum Index
HomeForumsMy TopicsCalendarEvent SignupsMemberlistOur C-DorysThe Brat MapPhotos

Need Help!! Never ending issue Suzuki DF150

 
Post new topic   Reply to topic    The C-Brats Forum Index -> General Chat
View previous topic :: View next topic  
Author Message
Easyvictor.14



Joined: 22 Feb 2015
Posts: 114
City/Region: Dallas
State or Province: TX
C-Dory Year: 2008
C-Dory Model: 23 Venture
Vessel Name: Easy Victor
Photos: Easy Victor
PostPosted: Wed Sep 19, 2018 3:53 pm    Post subject: Need Help!! Never ending issue Suzuki DF150 Reply with quote

OK brats,I have A recurring problem with my Suzuki DF 150 fuel injected 4 stroke. 2008 model on a 23 Venture.
Iíve been in 3 shops a total of 5 times and spent over $2800 so far.
The engine will start just fine, and run for about five or 10 minutes at 3800 to 5500 RPM then it will start to stutter stumble down to about 3000 RPM and never go back.
This is what has been done: water separator replaced, fuel vents re-oriented, loop in fuel vent lines, injectors rebuilt, vapor separator tank cleaned twice and replaced once, new fuel pump $$$, and ďvacuum leakĒ repaired (donít know what was supposedly leaking) both tanks pulled, cleaned, tested. The engine had 85 hrs on it when I bought it 3 yrs ago from Wefings, Now has 235 hrs. Been a huge pain in my butt, Iíve even thought of selling, but I wonít do that to someone. HELLLLPPPP!!!
All but one shop are in other states, and local shop wonít honor any work, they just want to keep throwing parts at it with my credit card.
There was some water in fuel originally, came in thru tank vents facing forward. That problem is fixed.

_________________
"New" 2008 23 Venture.
1992 Boston Whaler Montauk 17
1977 Sea Ray SRV 200 sold 2008
1981 T Craft 26 center console
1981 Silverton 34
1979 Chapparal 187
Many, many other small aluminum, wood and fiberglass toys!!!
Back to top
View user's profile Send private message Send e-mail
BrentB



Joined: 15 Jul 2006
Posts: 4231
City/Region: Greenwood
State or Province: IN
Photos: BrentB
PostPosted: Wed Sep 19, 2018 5:54 pm    Post subject: Reply with quote

Any water and debris in filter. I use a Racor water and gas filter with clear bowl to check.

Have all fuel hoses been replaced esp the ones inside the rigging tube? Hose can look good on outside but the inner hose can fail

What is the fuel pressure on the injector rail?

Do you have the factory shop manual? Any codes using diagnostic software.?

Take it back to Marc at Wefings?

_________________
Brent Barrett
Back to top
View user's profile Send private message
Easyvictor.14



Joined: 22 Feb 2015
Posts: 114
City/Region: Dallas
State or Province: TX
C-Dory Year: 2008
C-Dory Model: 23 Venture
Vessel Name: Easy Victor
Photos: Easy Victor
PostPosted: Wed Sep 19, 2018 8:42 pm    Post subject: Reply with quote

Yes, every fuel hose and filter has also been replaced, and it does it when run from a portable tank, so itís engine side. Donít know rail pressure, I have to assume Suzuki dealers checked that!
The most maddening part is, itís intermittent. Might start and run all day for several days, then start acting up. Sometimes it will clear after a shutdown for a few minutes, other times it wonít recover until it hits the shop.
Back to top
View user's profile Send private message Send e-mail
Da Nag



Joined: 23 Oct 2003
Posts: 2735
City/Region: Port Angeles
State or Province: WA
C-Dory Year: 2008
C-Dory Model: 16 Angler
Vessel Name: Taco
Photos: Da Boats
PostPosted: Wed Sep 19, 2018 9:18 pm    Post subject: Reply with quote

Sounds like venting/fuel flow could be a potential culprit, but even though you've looked into that - have you tried running it on a portable tank just to make sure?
_________________
Tux Will, C-Brat Nerd Tux
Back to top
View user's profile Send private message Send e-mail Visit poster's website
tsturm



Joined: 01 Nov 2003
Posts: 726
City/Region: Soldotna
State or Province: AK
C-Dory Year: 2003
C-Dory Model: 25 Cruiser
Vessel Name: JMR TOO
Photos: JMR-TOO
PostPosted: Wed Sep 19, 2018 10:20 pm    Post subject: Reply with quote

Easyvictor.14 wrote:
Yes, every fuel hose and filter has also been replaced, and it does it when run from a portable tank, so itís engine side. Donít know rail pressure, I have to assume Suzuki dealers checked that!
The most maddening part is, itís intermittent. Might start and run all day for several days, then start acting up. Sometimes it will clear after a shutdown for a few minutes, other times it wonít recover until it hits the shop.


Is the White E.C.M. power wire HOOKED DIRECTLY TO THE + POST OF A BATTERY, not through a switch, combiner or relay etc.?? Beer
Back to top
View user's profile Send private message
MikeR



Joined: 21 Apr 2013
Posts: 384
City/Region: Mill Creek
State or Province: WA
C-Dory Year: 2016
C-Dory Model: 22 Cruiser
Vessel Name: Big-C
Photos: MikeR
PostPosted: Wed Sep 19, 2018 11:50 pm    Post subject: Reply with quote

It sounds like something is tripping the over-rev caution system, which on the DF150 limits the throttle to 3000 rpm. Next time it happens, try to re-set it by reducing throttle all the way to idle for at least 1 second (I'd even go into neutral, just to be sure), then see if you can get above 3000 again. That's what the Suzuki manual says, and it's the exact same procedure as my Merc (which limits to 2500 rpm). The owners manuals provide virtually no information on what sensors play into this "feature", but in doing some research, it's more than just over-revs, at least on the Merc. It seems to be a combination of different sensors and from what I've gathered, protects the engine from some kind of perceived over-load condition and can happen at any RPMs above the protection limit (3000 in your case) not just RPMs above the max RPM rating. It could be a bad sensor...Mechanics may insist bad sensors will always throw a code, but I've heard from others who have replaced sensors like TPS or CPS which never threw codes, and their intermittent problems disappeared. Just a thought since it sounds like you've already checked all the fuel systems, and since it is so randomly intermittent.

-Mike

_________________
22' C-Dory Cruiser "Big C"
16' C-Dory Angler "Lil'C" (Sold May 2017)
10' C-Dory Row Boat "Baby C"
Back to top
View user's profile Send private message
Easyvictor.14



Joined: 22 Feb 2015
Posts: 114
City/Region: Dallas
State or Province: TX
C-Dory Year: 2008
C-Dory Model: 23 Venture
Vessel Name: Easy Victor
Photos: Easy Victor
PostPosted: Thu Sep 20, 2018 9:07 am    Post subject: Reply with quote

OK! Iíll check the dreaded ďwhite wireĒ, thanks Dave.
Also, itís not throwing any codes, but Iíll check into rev limiter and sensors.
All the shops have focused on fuel, but Iím leaning electrical also.
Back to top
View user's profile Send private message Send e-mail
Wefings
Dealer


Joined: 29 Nov 2005
Posts: 2066
City/Region: Panhandle
State or Province: FL
Photos: Cruise Ship #4
PostPosted: Thu Sep 20, 2018 4:32 pm    Post subject: Reply with quote

Change the spark plugs if you haven't already . Really ...........
They fail .
Marc

_________________
Wefings Marine Website
Since 1909
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Easyvictor.14



Joined: 22 Feb 2015
Posts: 114
City/Region: Dallas
State or Province: TX
C-Dory Year: 2008
C-Dory Model: 23 Venture
Vessel Name: Easy Victor
Photos: Easy Victor
PostPosted: Thu Sep 20, 2018 5:14 pm    Post subject: Reply with quote

Changed plugs already also. Iíll be back at the boat Sunday and Iíll start checking these items. Itís just frustrating to have spent almost $3000 on ďrepairsĒ that didnít fix anything. I canít go back to the shops because theyíre behind me on the Loop, and the boat is now back in Texas for the winter.
Back to top
View user's profile Send private message Send e-mail
DavidM



Joined: 24 Dec 2017
Posts: 92
City/Region: Punta Gorda
State or Province: FL
C-Dory Year: 2006
C-Dory Model: 22 Cruiser
PostPosted: Thu Sep 20, 2018 6:44 pm    Post subject: Reply with quote

Are you sure that the fuel tank, the fuel pickup, the valve if it has one, any fuel filter and all of the plumbing to the carb or EFI is clean with no blockages.

Years ago I had a motorcycle that acted just like your engine. Turned out it was a blocked fuel pickup tube.

David
Back to top
View user's profile Send private message Send e-mail
Easyvictor.14



Joined: 22 Feb 2015
Posts: 114
City/Region: Dallas
State or Province: TX
C-Dory Year: 2008
C-Dory Model: 23 Venture
Vessel Name: Easy Victor
Photos: Easy Victor
PostPosted: Thu Sep 20, 2018 8:02 pm    Post subject: Reply with quote

Yep. Ran it off a portable tank. Same results.
Back to top
View user's profile Send private message Send e-mail
DrewbirdII



Joined: 29 Sep 2012
Posts: 39
City/Region: fanny bay
State or Province: BC
C-Dory Year: 1989
C-Dory Model: 22 Cruiser
Vessel Name: Drewbird II
PostPosted: Thu Sep 20, 2018 9:06 pm    Post subject: Reply with quote

Maybe a faulty 02 censor, or the tiny HP fuel filter in the fuel rail is partially plugged? Jim
Back to top
View user's profile Send private message Send e-mail
BrentB



Joined: 15 Jul 2006
Posts: 4231
City/Region: Greenwood
State or Province: IN
Photos: BrentB
PostPosted: Sat Sep 22, 2018 8:44 am    Post subject: Reply with quote

Do you have the factory shop manual? Diagnostic software kit is available, too.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The C-Brats Forum Index -> General Chat All times are GMT - 6 Hours
Page 1 of 1

 
     Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum



Page generation time: 0.0732s (PHP: 63% - SQL: 37%) - SQL queries: 30 - GZIP disabled - Debug on